woodcorpse的个人博客分享 http://blog.sciencenet.cn/u/woodcorpse

博文

扩增子分析QIIME. 3以管理员安装QIIME1.9.1至Ubuntu16.04

已有 3916 次阅读 2017-7-15 07:00 |个人分类:扩增子|系统分类:科研笔记|关键词:学者

image

科学网对Markdown排版支持较差,对格式不满意的用户请跳转至 CSDN“宏基因组”公众号阅读;

想了解更多16S/ITS/18S扩增子、宏基因组、宏转录组文献阅读和分析相关文章,快关注“宏基因组”公众号,干货第一时间推送。
image

系统学习生物信息,快关注“生信宝典”,那里有几千志同道合的小伙伴一起学习。
image

Install QIIME 1.9.1 on Ubuntu 16.04 Desktop LTS x64

所有公共软件、数据库,全部以yongxin(我的用户名)用户安装,为使计算机所有用户使用,此用户需要管理员权限。

查看系统信息,安装依赖的必须软件# 查看系统版本 lsb_release -a # Ubuntu 16.04 LTS # 查看python版本 python --version # 安装python增强包 sudo apt-get install build-essential python-dev python-pip sudo pip install numpy # 手动安装如下包,否则使用pip安装QIIME会报错 # Required for pip install qiime # Install freetype https://www.freetype.org/download.html cd /home/yongxin/bin wget http://download.savannah.gnu.org/releases/freetype/freetype-2.6.3.tar.gz tar -xvzf freetype-2.6.3.tar.gz cd  freetype-2.6.3 ./configure # 提示还依赖一些包 zlib, bzip2, libpng, harfbuzz make sudo make install # Install zlib http://www.zlib.net/ cd /home/yongxin/bin wget http://zlib.net/zlib-1.2.8.tar.gz tar xvzf zlib-1.2.8.tar.gz cd zlib-1.2.8 ./configure make sudo make install # Install libpng http://www.libpng.org/pub/png/libpng.html required zlib cd /home/yongxin/bin wget ftp://ftp.simplesystems.org/pub/libpng/png/src/libpng16/libpng-1.6.22.tar.gz tar -xvzf libpng-1.6.22.tar.gz cd libpng-1.6.22 ./configure # zlib not install make sudo make install 安装qiime# HDF5,required by H5PY, https://www.hdfgroup.org/HDF5/release/obtain5.html cd /home/yongxin/bin wget https://www.hdfgroup.org/ftp/HDF5/releases/hdf5-1.8.4/src/hdf5-1.8.4.tar.gz tar xvzf hdf5-1.8.4.tar.gz cd hdf5-1.8.4/ make sudo make install sudo pip install h5py # 安装qiime主程序及脚本 sudo pip install qiime # 测序QIIME是否安装成功 print_qiime_config.py 安装R及相关包sudo apt-get install r-base # R package sudo R install.packages(c('ape','biom','optparse','RColorBrewer','randomForest','vegan'), repo="http://cran.us.r-project.org") source('http://bioconductor.org/biocLite.R') biocLite(c('DESeq2','metagenomeSeq')) q() qiime deploy 安装QIIME依赖软件和数据库cd /home/yongxin/bin wget https://codeload.github.com/qiime/qiime-deploy/zip/master # 布署脚本 mv master qiime-deploy.zip unzip qiime-deploy.zip mv qiime-deploy-master/ qiime/ cd qiime/ wget https://codeload.github.com/qiime/qiime-deploy-conf/zip/master # 布署脚本相关配置文件 mv master qiime-deploy-conf.zip unzip qiime-deploy-conf.zip mv qiime-deploy-conf-master/ qiime-deploy-conf sudo apt-get install vim sudo vim /etc/apt/sources.list # "deb http://cran.rstudio.com/bin/linux/ubuntu trusty/" in bottom # 添加R的库存地址,为更新R至新版 sudo apt-get -y update # 更新库存列表 sudo apt-get --force-yes -y install python-dev libncurses5-dev libssl-dev libzmq-dev libgsl0-dev openjdk-6-jdk libxml2 libxslt1.1 libxslt1-dev ant git subversion build-essential zlib1g-dev libpng12-dev libfreetype6-dev mpich2 libreadline-dev gfortran unzip libmysqlclient18 libmysqlclient-dev ghc sqlite3 libsqlite3-dev libc6-i386 libbz2-dev tcl-dev tk-dev r-base r-base-dev libatlas-dev libatlas-base-dev liblapack-dev swig libhdf5-serial-dev # 安装依赖包 sudo apt-get install default-jre sudo apt-get install default-jdk sudo apt-get install ant sudo python qiime-deploy.py $HOME/bin/qiime/ -f $HOME/bin/qiime/qiime-deploy-conf/qiime-1.9.1/qiime.conf --force-remove-failed-dirs # failed to deploy: vienna, qiime-galaxy, galaxy, ampliconnoise, bwa, ea-utils, SeqPrep # denoiser cd /usr/local/lib/python2.7/dist-packages/qiime/support_files/denoiser/FlowgramAlignment sudo mkdir ../../../../scripts sudo apt-get install ghc sudo make sudo ln `pwd`/FlowgramAli_4frame /usr/local/bin/ -s # download usearch 5.2 from http://www.drive5.com/usearch/, need user apply cd ~/bin/ sudo ln /home/yongxin/bin/usearch* /usr/bin/usearch -s # AmpliconNoise # MPI Required http://www.open-mpi.org/ cd /home/yongxin/bin wget https://www.open-mpi.org/software/ompi/v1.10/downloads/openmpi-1.10.2.tar.gz tar xvzf openmpi-1.10.2.tar.gz cd openmpi-1.10.2 ./configure sudo make all install # chimera checker Perseus requires that both MAFFT and the Gnu Science Library # mafft http://mafft.cbrc.jp/alignment/software/ sudo apt-get install mafft # GSL http://www.gnu.org/software/gsl/ wget ftp://ftp.gnu.org/gnu/gsl/gsl-2.1.tar.gz tar xvzf gsl-2.1.tar.gz cd gsl-2.1 ./configure make make check sudo make install sudo make install check # AmpliconNoise cd /home/yongxin/bin wget http://ampliconnoise.googlecode.com/files/AmpliconNoiseV1.27.tar.gz # fail download try copy from Hanlab scp test@124.16.152.56:/home/public/bin/AmpliconNoiseV1.27.tar.gz ./ tar xvzf AmpliconNoiseV1.27.tar.gz cd  AmpliconNoiseV1.27 make sudo make install sudo vim /etc/bash.bashrc #export PATH=/home/yongxin/bin/AmpliconNoiseV1.27/bin:/home/yongxin/bin/AmpliconNoiseV1.27/Scripts:$PATH #export PYRO_LOOKUP_FILE=/home/yongxin/bin/AmpliconNoiseV1.27/Data/LookUp_E123.dat #export SEQ_LOOKUP_FILE=/home/yongxin/bin/AmpliconNoiseV1.27/Data/Tran.dat print_qiime_config.py -tf # AmpliconNoise, denoiser, usearch

刚看到QIIME网站发布的通知,QIIME1将于明年停止维护,并由QIIME2接档,看来我的分析流程也要过时了。所以计划近斯抢先发布发布QIIME2的教程。欢迎大家多支持。但由于多数人还是使用QIIME1,它的流程我也会逐渐分享,供大家交流和讨论。

QIIME 2 will succeed QIIME 1 on January 1, 2018. QIIME 1 will no longer be supported at that time, as development and support effort for QIIME will be focused entirely on QIIME 2.

We recommend that existing QIIME users begin transitioning from QIIME 1 to QIIME 2 now. If you’re new to QIIME, you should start by learning QIIME 2, not QIIME 1.

This site documents QIIME 1. To learn more about QIIME 2, see https://qiime2.org.

Reference
  1. http://qiime.org/install/index.html


https://m.sciencenet.cn/blog-3334560-1066440.html


下一篇:扩增子分析QIIME2. 1简介和安装

0

该博文允许注册用户评论 请点击登录 评论 (0 个评论)

数据加载中...
扫一扫,分享此博文

Archiver|手机版|科学网 ( 京ICP备07017567号-12 )

GMT+8, 2023-2-1 01:54

Powered by ScienceNet.cn

Copyright © 2007- 中国科学报社

返回顶部